subject
Computers and Technology, 15.10.2020 19:01 8hoofs

HW3_P2 - MyString The String class is provided in the Java library. Provide your own implementation for the following methods (name the new class MyString):
**PLEASE DO NOT USE THE STRING OBJECT AND ITS METHODS. IMPLEMENT THEM ALL AGAIN YOURSELF!
**You can use char[] array and Character object.
public MyString(char[] chars);
public char charAt(int index);
public int length();
public MyString substring(int begin, int end);
public MyString toLowerCase();
public boolean equals(MyString s);
public static MyString valueOf(int i); // Convert int type to MyString type
public char[] toChars();
Sample Input1: Test Length() Method
1
abcdef
Sample Output1: Test Length() Method
4
Sample Input2: Test charAt() Method
2
abcdfeg
3
Sample Output2: Test charAt() Method
d
Sample Input3: Test substring() Method
3
abcdefrgggfhgfgfhfgy
0
4
Sample Output3: Test substring() Method
abcd
Sample Input4: Test equals() Method
4
abcdefghi
sqsq
Sample Output4: Test equals() Method
false
Sample Input5: Test toLowerCase() Method
5
ABcDEfGHi
Sample Output5: Test toLowerCase() Method
abcdefghi
Sample Input6: Test valueOf() Method
6
9876543
Sample Output6: Test valueOf() Method
9876543
*Drivers Class*
import java. util.*;
import java. lang.*;
import java. io.*;
public class Driver {
public static void main(String[] args){
String str = null;
MyString s = null;
Scanner input = new Scanner(System. in);
int which = input. nextInt();
if(which!=6)
str = input. next();
switch (which) {
case 1 : // test length method
s = new MyString(str. toCharArray());
System. out. println(s. length());
break;
case 2 : // test charAt method
s = new MyString(str. toCharArray());
System. out. println(s. charAt(input. nextInt()));
break;
case 3 : // test substring method
s = new MyString(str. toCharArray());
System. out. println(new String(s. substring(input. nextInt(), input. nextInt()).toChars()));
break;
case 4 : // test equals method
String str2 = input. next();
s = new MyString(str. toCharArray());
MyString s2 = new MyString(str2.toCharArray());
System. out. println(s. equals(s2));
break;
case 5 : // test toLowerCase method
s = new MyString(str. toCharArray());
System. out. println(new String(s. toLowerCase().toChars()));
break;
case 6 : // test valueOf method
System. out. println(new String(MyString. valueOf(input. nextInt()).toChars()));
break;
}
}
}
*Solution class*
import java. util.*;
import java. lang.*;
import java. io.*;
//toChars() method is already implemented, so plese do not change it
class MyString {
private char[] chars;
public MyString(char[] chars) {
}
public char[] toChars() { //Do not change this method
return chars;
}
public int length()
}
public char charAt(int index) {
}
public MyString substring(int begin, int end) {
}
public boolean equals(MyString s){
}
public MyString toLowerCase() {
}
//convert an int type to MyString type
public static MyString valueOf(int i) {
}
}
Dont change driver class or myString. just add code

ansver
Answers: 2

Another question on Computers and Technology

question
Computers and Technology, 23.06.2019 10:00
Now, open this passage to read about fafsa requirements. describe the information you will need to provide in order to complete a fafsa. list at least three of the required documents you must include.
Answers: 3
question
Computers and Technology, 23.06.2019 12:40
According to the video what are some tasks petroleum engineers perform check all that apply
Answers: 2
question
Computers and Technology, 23.06.2019 19:30
You can apply several different worksheet themes from which tab?
Answers: 1
question
Computers and Technology, 23.06.2019 23:30
The keyboard usually has six rows of keys. which of the following is not one of the key group categories? letter keys number keys control keys graphic keys
Answers: 1
You know the right answer?
HW3_P2 - MyString The String class is provided in the Java library. Provide your own implementation...
Questions
question
Mathematics, 10.03.2021 23:40
question
History, 10.03.2021 23:40
question
Mathematics, 10.03.2021 23:40
question
Mathematics, 10.03.2021 23:40
question
Medicine, 10.03.2021 23:40
question
Mathematics, 10.03.2021 23:40
Questions on the website: 13722361